Resolu : Erreur 404 suite installation

Besoin d'aide ?
yves-marie
Messages : 5
Inscription : 31 mars 2017, 15:47

Resolu : Erreur 404 suite installation

Messagepar yves-marie » 31 mars 2017, 16:02

Bonjour,

Piqué par la curiosité suite à votre présence au salon Marketing for Business, je viens d'installer Creme 1.6
L'installation s'est bien passée (a priori) mais je ne peux pas accéder au site : Erreur 404.
Comment puis-je en savoir plus ?
La console de Chrome me renvoie deux erreurs d'accès à la ressource pour les css

Merci de votre aide

Yves-Marie Malphettes
Dernière édition par yves-marie le 18 avr. 2017, 07:21, édité 1 fois.

Avatar de l’utilisateur
genglert
Messages : 130
Inscription : 06 juin 2011, 10:54

Re: Erreur 404 suite installation

Messagepar genglert » 31 mars 2017, 18:44

Bonjour,

Vous avez suivi le tutoriel d'installation de la version 1.6 (viewtopic.php?t=651&p=1039#p1039) ?
Vous utilisez le serveur de développement (auquel cas il faut regarder la console dans lequel vous l'avez lancé) ? Apache/nginx/... (dans le cas il faut regarder les logs spécifiques du serveur) ?
Votre erreur 404 est-elle l'erreur 404 de Creme (elle est 'jolie') ou bien celle du serveur ?
Si vous utilisez le serveur de dev, avez vous bien mis le port 8000 dans votre barre d'adresse ?

yves-marie
Messages : 5
Inscription : 31 mars 2017, 15:47

Re: Erreur 404 suite installation

Messagepar yves-marie » 31 mars 2017, 21:18

Bonsoir,

Pour l'installation, j'ai suivi votre tutoriel (complété par celui de mon hébergeur pour l'environnement python, car les commandes de virtualenv du tutoriel ne donnaient rien)
Je pense que l'erreur 404 est celle de Creme (elle ressemble à vote template) : voir PJ
Je suis sur le serveur Apache
log apache :
[Fri Mar 31 22:12:02 2017] [error] [client 82.67.237.62] File does not exist: /home/ymmalphettes/www/static_media, referer: http://ymmalphettes.alwaysdata.net/creme
[Fri Mar 31 22:12:03 2017] [error] [client 82.67.237.62] File does not exist: /home/ymmalphettes/www/static_media, referer: http://ymmalphettes.alwaysdata.net/creme

log uwsgi :
*** Starting uWSGI 2.0.14 (64bit) on [Fri Mar 31 21:44:18 2017] ***
compiled with version: 4.9.2 on 26 December 2016 14:42:17
os: Linux-4.4.36-alwaysdata #1 SMP Tue Dec 6 09:12:06 UTC 2016
nodename: http1
machine: x86_64
clock source: unix
pcre jit disabled
detected number of CPU cores: 12
current working directory: /home/ymmalphettes
detected binary path: /usr/alwaysdata/uwsgi/2.0.14/bin/uwsgi
chdir() to /home/ymmalphettes/creme_crm-1.6/
your processes number limit is 257250
your memory page size is 4096 bytes
detected max file descriptor number: 1048576
building mime-types dictionary from file /etc/mime.types...547 entry found
lock engine: pthread robust mutexes
thunder lock: enabled
[busyness] settings: min=10%, max=90%, overload=5, multiplier=10, respawn penalty=2
[busyness] backlog alert is set to 33 request(s), step is 1
[busyness] backlog non-zero alert is set to 60 second(s)
uwsgi socket 0 bound to TCP address 127.2.19.148:8100 fd 3
Python version: 2.7.13 (default, Mar 14 2017, 18:26:46) [GCC 4.9.2]
Set PythonHome to /home/ymmalphettes/creme/
*** Python threads support is disabled. You can enable it with --enable-threads ***
Python main interpreter initialized at 0x257ae00
your server socket listen backlog is limited to 100 connections
your mercy for graceful operations on workers is 60 seconds
mapped 800360 bytes (781 KB) for 10 cores
*** Operational MODE: preforking ***
*** uWSGI is running in multiple interpreter mode ***
spawned uWSGI master process (pid: 2190892)
spawned uWSGI worker 1 (pid: 2190895, cores: 1)
/home/ymmalphettes/creme/lib/python2.7/site-packages/mediagenerator/utils.py:7: RemovedInDjango19Warning: django.utils.importlib will be removed in Django 1.9.
from django.utils.importlib import import_module
WSGI app 0 (mountpoint='') ready in 0 seconds on interpreter 0x257ae00 pid: 2190895 (default app)
Pièces jointes
Capture d’écran 2017-03-31 à 21.45.56.png
page 404
Capture d’écran 2017-03-31 à 21.45.56.png (38.18 Kio) Consulté 824 fois

Avatar de l’utilisateur
jmarmand
Messages : 106
Inscription : 05 juin 2011, 18:12

Re: Erreur 404 suite installation

Messagepar jmarmand » 04 avr. 2017, 10:03

Bonjour,

nous ne vous oublions pas.

Je reviens vers vous avec des éléments de réponse d'ici demain soir.

yves-marie
Messages : 5
Inscription : 31 mars 2017, 15:47

Re: Erreur 404 suite installation

Messagepar yves-marie » 04 avr. 2017, 13:17

Bonjour,

Je soupçonne un paramétrage incorrect de l'interface uWSGI qui remplace mod_wsgi pour l'acces distant au site.

Du coup, j'ai essayé une installation en local mais qui n'est pas terminée car beaucoup moins simple (des erreurs pratiquement à chaque ligne du requirements.txt...

Yves-Marie

yves-marie
Messages : 5
Inscription : 31 mars 2017, 15:47

Re: Erreur 404 suite installation

Messagepar yves-marie » 12 avr. 2017, 08:28

Bonjour,

Avez-vu pu avancer sur ma question ?

Cordialement,

Yves-Marie MAlphettes

Avatar de l’utilisateur
jmarmand
Messages : 106
Inscription : 05 juin 2011, 18:12

Re: Resolu : Erreur 404 suite installation

Messagepar jmarmand » 24 avr. 2017, 20:29

Bonsoir,

nous avons eu un emploi du temps un peu plus chargé que prévu, je n'ai pas eu une seconde pour avancer sur votre problème avant ce soir.

A priori là, si j'en crois le message d'erreur '/home/ymmalphettes/www/static_media' , il semblerait que le repertoire en question n'existe pas. Il faudrait que vous vous vérifiez cela.

Ensuite, concernant l'hébergement Alwaysdata. si vous êtes passés en uwsgi, vous devriez avoir quelques part dans votre config apache des choses ressemblant à cela :

Alias /site_media/ /REPERTOIRE_VERS_STATIC
<Directory /REPERTOIRE_VERS_STATIC>
Options Indexes SymLinksIfOwnerMatch
AllowOverride AuthConfig Limit FileInfo Indexes
Order deny,allow
Allow from all
</Directory>



(ici vous devez remplacer /site_media/ par l'url que vous avez défini en configuration pour les statics et REPERTOIRE_VERS_STATIC par le repertoire qui va bien) .

Vous devez aussi avoir quelque chose comme :

ProxyPassMatch ^/site_media/ !

Si vous avez tout cela, que le répertoire du début de mon billet existe bien et que vous êtes toujours bloqué, je vous propose de m'envoyer les fichiers de config apache et uwsgi à jmarmand AT hybird DOT org. Je pourrais y jeter un coup d'oeil pendant le prochain week end de 3 jours.

yves-marie
Messages : 5
Inscription : 31 mars 2017, 15:47

Re: Resolu : Erreur 404 suite installation

Messagepar yves-marie » 25 avr. 2017, 08:26

Bonjour,

J'ai résolu mon problème différemment : en reconfigurant uwsgi.

J'ai supprimé les chemins statiques et réglé l'adresse directement à la racine : ymmalphettes.alwaysdata.net
Ce n'est certainement pas conventionnel mais tout marche, excepté la génération des pdf (devis commandes) : il n'arrive pas à accéder au dossier 'media/upload/billing'
Pourtant l'accès aux dossiers 'media/upload/documents' et 'media/upload/emails' se fait correctement.

Quels chemins statiques faut-il définir ?

Yves-Marie Malphettes


Revenir vers « Questions »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité